PerformancePoint Server – Dashboard Designer run error (Unauthorized 401)

        Last week I had a problem with my PerformancePoint Dashboard Designer.  I have installed MS Office PerformancePoint 2007 Monitoring Server on one machine. When I was running the Dashboard Designer on this machine everything was working correctly (by using Monitoring Central Site and button [RUN] Dashboard Designer downloaded and run well).
But when I was trying to run the Dashboard Designer on a user’s machine (by using Monitoring Central Site also) when I clicked link to this application in a browser, a browser raised a small message window with the Unauthorized (401) error from the server ("Cannot retrieve application.Authentication error").
See the screenshot below.

Under the Details… button was available the following error log:

PLATFORM VERSION INFO
Windows    : 5.1.2600.131072 (Win32NT)
Common Language Runtime  : 2.0.50727.832
System.Deployment.dll   : 2.0.50727.832 (QFE.050727-8300)
mscorwks.dll    : 2.0.50727.832 (QFE.050727-8300)
dfdll.dll    : 2.0.50727.42 (RTM.050727-4200)
dfshim.dll    : 2.0.50727.42 (RTM.050727-4200)
SOURCES
Deployment url   : http://bits:40000/DesignerInstall/
ERROR SUMMARY
Below is a summary of the errors, details of these errors are listed later in the log.
* Activation of http://bits:40000/DesignerInstall/ resulted in exception. Following failure messages were detected:
  + Downloading http://bits:40000/DesignerInstall/ did not succeed.
  + The remote server returned an error: (401) Unauthorized.
COMPONENT STORE TRANSACTION FAILURE SUMMARY
No transaction error was detected.
WARNINGS
There were no warnings during this operation.
OPERATION PROGRESS STATUS
* [2007-12-14 15:56:41] : Activation of http://bits:40000/DesignerInstall/ has started.
ERROR DETAILS
Following errors were detected during this operation.
* [2007-12-14 15:56:43] System.Deployment.Application.DeploymentDownloadException (Unknown subtype)
  – Downloading http://bits:40000/DesignerInstall/ did not succeed.
  – Source: System.Deployment
  – Stack trace:
   at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)
   at System.Deployment.Application.SystemNetDownloader.DownloadAllFiles()
   at System.Deployment.Application.FileDownloader.Download(SubscriptionState subState)
   at System.Deployment.Application.DownloadManager.DownloadManifestAsRawFile(Uri& sourceUri, String targetPath, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
   at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestDirectBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
   at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options)
   at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut)
   at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)
  — Inner Exception —
  System.Net.WebException
  – The remote server returned an error: (401) Unauthorized.
  – Source: System
  – Stack trace:
   at System.Net.HttpWebRequest.GetResponse()
   at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)
COMPONENT STORE TRANSACTION DETAILS
No transaction information is available.

Important thing was that my client’s machine was not joined to the same domain that PerformancePoint Server machine was (I was only using a domain account to log into PPS Server).
And this small detail was a reason of all this problem.
Logging to the Central Monitoring Server Site was not a problem (web browser asked me for credentials – domain account and password).
But this was insufficient to download a Dashboard Designer application. Unfortunately after click Run web browser didn’t ask me for any credentials.
It just raised the message with an error depicted above. I thought that while I was asked to pass my domain account and password the cause of this problem was not bound with that my machine was not in the same domain with PerformancePoint Server. But as I turned out later,  I was wrong.
The main reason of this problem was that I was not logged to domain (I was only using domain credentials in browser to log into PerformancePoint Monitoring Central).
Usually when we are working in the same domain this problem will not appear.
But when we are working with different domains this problem may occur. So how to solve it?

The solution is quite simple and easy.
We need to tell our OS what credentials should be used while accessing a particular server (by managing passwords stored on the computer).
Instruction which tells how to manage passwords on your computer you can find under the following link (for Windows XP):
Managing passwords stored on a computer

By using it you need to add your server and credentials to list of your passwords, so while attempting to download a Dasboard Designer your OS will use proper account and password to access it. And this error will not occur even if your computer is connected to a different domain.

Update:
Recently while testing one of my installations of PPS Monitoring I discovered that if I had configured my web browser to ask my credentials while connecting to Monitoring Central Page ("Always ask for user and password" option was checked in my browser) it is important to check Save password option while entering my login and password for the first time. Without ticking the "Save password" option I got the same error 401 while attempting to download the Dashboard Designer.
When I set "Save password" option the Dashboard Designer downloaded without any problems.

 

Advertisements
This entry was posted in PerformancePoint Server 2007. Bookmark the permalink.

16 Responses to PerformancePoint Server – Dashboard Designer run error (Unauthorized 401)

  1. Brad says:

    I like the article you wrote, but I am very interested in the "Managing Passwords stored on the computer" link, which appears to be broken.

  2. Radosław says:

    Thanks for your watchfulness and nice comment. 😉
    The original page about Managing passwords stored on a computer  was moved so I have already updated this link.
    Now it works (but I \’m not sure for how long). 🙂 
     
    Best regards,
     

  3. T8tube.com says:

    good

  4. peng says:

    Hi, I have the same issue, you post really helps solving the problem. I am not sure if you running into problem when preview and publish the dashboard. When user uses a machine that is not on the domain, the preview page will open up, but there\’s a javascript error saying "access is denied". And when the user publish the dashboard, the Dashboard designer will say the SharePoint URL is invalid even though the user can access the sharepoint site. Do you have any solution to these problems? Thanks in advance.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s